Cisco Netflow Configuration

% Network No Comments »

Cisco cihazları kullandığınız bir ağda, cihazların oluşturduğu netflow datalarını (ağ akışı) bir yerlerde tutmanız ve trafik analizi, trafik gözlemlemesi yapmanız gerekebilir. Bunun için aşağıdaki komutları kullanabilirsiniz.

#ip flow-export destination ipaddress port

#ip flow-export source interface

#ip flow-export version number

Bu komutlar sayesinde oluşan flow datalarını, bir ip adresine belirli bir porttan gönderiyorsunuz. Ayrıca bu ip adresi ve portla erişim kurulacak interface’i belirliyorsunuz. Gönderilen flow datalarından, netflow server tarafından anlaşılır bir istatistik oluşturması için uyumlu versiyonu belirtiyorsunuz.

Cihaz tarafından netflow server’a gönderilen flow data istatistiklerini görmek içinse cihazda aşağıdaki komutu girmeniz yeterli olacaktır.

#ip route-cache flow

16 Cisco Error Message Decoder

% Network No Comments »

Cisco Error Message Decoder (ben kendisine cisco debugger diyorum); Cisco ağ cihazlarında karşılaştığınız hata mesajlarının ne anlama geldiğini ve ne yapmanız gerektiğini size basit bir şekilde sunan, güzel bir web uygulamasıdır. Kendisine aşağıdaki adresten erişebilirsiniz.

http://www.cisco.com/cgi-bin/Support/Errordecoder/index.cgi

Karşınıza gelen ekranda, Paste Error Message: mesajının yanındaki kutucuğa, aldığınız hata mesajının hata kodunu giriniz ve Submit’e tıklayınız. Olay bu kadar basit hata mesajı koduna gelince; Cisco cihazlar hata mesajı vermeden hemen önce hata mesaj kodunu da verirler ve bu kod % işareti ile başlar. Sizin bu kutucuğa gireceğiniz kod da bu olmalıdır.
Örneğin; %PLATFORM_CAT2950-3-ASIC_BIST_FAILURE yazıp Submit dediğimizde aşağıdaki gibi birşeyle karşılaşırız.

Read the rest of this entry »

Cisco ASA üzerinde SMTP ve POP3 Erişimi

% Network No Comments »

Cisco ASA 5500 serisi üzerinde smtp ve pop3 portlarını açmak ve mail trafiğine izin vermek için aşağıdaki kuralları işletmeniz gerekiyor.

Dış interface’in ip adresinin 10.0.0.1 olduğunu kabul edelim ve mail sunucunun ip adresinin de 192.168.1.10 olduğunu varsayalım. Bu örneğe göre kurallarımız şu şekilde olacaktır;

access-list Outside_access_in extended permit tcp any host 10.0.0.1 eq pop3
access-list Outside_access_in extended permit tcp any host 10.0.0.1 eq smtp

static (Inside,Outside) tcp 10.0.0.1 pop3 192.168.1.10 pop3 netmask 255.255.255.255
static (Inside,Outside) tcp 10.0.0.1 pop3 192.168.1.10 smtp netmask 255.255.255.25

Cisco ipv6 Tunneling Configuration

% Network 1 Comment »

ipv6 over ipv4 tunneling:

cisco(config)# interface tunnel test
cisco(config-if)# tunnel description test
cisco(config-if)# tunnel source interface-id
cisco(config-if)# tunnel destination A.B.C.D
cisco(config-if)# ipv6 address X:X:X:X::X/X
cisco(config-if)# tunnel mode ipv6ip
cisco(config-if)# ipv6 enable

ipv6 over ipv6 tunneling:

cisco(config)# interface tunnel test
cisco(config-if)# tunnel description test
cisco(config-if)# tunnel source interface-id
cisco(config-if)# tunnel destination A:B:C:D:E:F:G:H
cisco(config-if)# ipv6 address A:B:C:D:E:F:G:H/X
cisco(config-if)# tunnel mode ipv6ip
cisco(config-if)# ipv6 enable

ipv6 route configuration:

cisco(config)# ipv6 route

MTU configuration:

cisco(config-if)# ipv6 mtu VALUE MTU (bytes)

ipv6 ping:

# ping6 -c 1 2001:660:7303:7001::1

ipv6 traceroute:

# traceroute6 www.bugrakeskin.com

ipv6 tracepath:

# tracepath6 www.bugrakeskin.com

Cisco NAT Uygulamaları

% Network No Comments »

NAT -açılımını da yazayım bari tam olsun; “Network Address Translation”- bizim gateway olarak çalışan router üzerinden giden ve gelen paketlerin kaynak adresi ya da hedef adresini değiştirmemizi sağlayan bir -teknolojidir desem olmaz- uygulamadır. NAT iki şekilde yapılır; ya giden pakette NAT uygulanır, ya da gelen paketteNAT uygulanır.

Inside NAT: Local ağınızdan dışarıya giden paketlerin kaynak ip adresini değiştirmek için uygulanır. Bu durumda giden pakette kaynak adresi değiştiği için ve bu giden pakete bir cevap geleceğinden otomatik olarak dışarıdan geri içeri gelecek paketin de hedef adresi değişmiş olur.

Read the rest of this entry »

Cisco cihazlarda DHCP konfigurasyonu

% Network 1 Comment »

Diyelim ki network altyapınızda kullandığınız Cisco cihazınız ile aynı zamanda network kullanıcılarına otomatik ip dağıtmak (dhcp) istiyorsunuz. Böyle bir ihtiyacın ortaya çıkabileceğinden dolayı tüm Cisco router’ların üzerinde bulunan IOS’ler ile  dhcp-server desteği beraber geliyor. Aşağıdaki adımlarla Cisco router’inizi bir dhcp sunucusu gibi çalıştırabilirsiniz.

cisco#conf t
cisco(config)#ip dhcp pool (IP pool’a isim vermek)
cisco(config)#ip dhcp excluded-address 192.168.1.10 – 192.168.1.100 (hangi ip aralıklarının dağıtılmayacağı belirlenir)
cisco(config)#ip dhcp pool lokal-network (dhcp pool oluşturulur)
cisco(dhcp-config)#network 192.168.1.0 255.255.255.0 (network id tanımlanır)
cisco(dhcp-config)#default-router 192.168.1.1 (default gateway tanımlanır)
cisco(dhcp-config)#dns-server 192.168.1.2 (dns sunucusu belirlenir)
cisco(dhcp-config)#domain-name bugrakeskin.com (domain belirlenir)
cisco(dhcp-config)#exit
cisco(config)#interface FastEthernet0/1
cisco(config-if)#ip address 192.168.1.1 255.255.255.0
cisco(config-if)#end
cisco#wri mem

Read the rest of this entry »

Entries RSS Comments RSS Log in
Follow

Get every new post delivered to your Inbox

Join other followers